Cisco Packet Tracer Nedir? - Mustafa Sabri OĞUZ

Duyurular

16 Ocak 2019 Çarşamba

Cisco Packet Tracer Nedir?

Packet Tracer, Cisco tarafından üretilen Router, Switch, Hub gibi cihazların gerçek ağda kurulmadan önce ve hata payını en aza indirmek ve sistemi projelendirmek adına, bütün ayrıntıları ile (Cihaz komut sistemi arayüzünden tutun da, Ip adresleri, DHCP yapılandırması gibi ) gerçek bir sistem oluşturma simülasyon programıdır.

Cisco packet tracer ile yukarıda ki gibi bir "Site To Site" topoloji oluşturuyoruz. Amacımız 10 adet VLan oluşturmak ve Server üzerinde yapacağımız DHCP yapılandırması ile client bilgisayarların kendi Vlanları üzerinden otomatik ip alması.
İlk olarak Topolojimiz üzerinden DHCP Serverımız için statik ip tanımlamamız gerekiyor. Bunun için sunucuyu seçin.
Açılan pencerenin üst sekmesinde bulunan "Desktop" seçeneğini seçin. Ardından "Ip Configuration" seçeneğini seçin.
Bu pencereden "Static" seçeneğinin seçili olması gerekiyor. Daha sonra Ip Adresi olarak "192.34.99.100", subnet maskesi olarak "255.255.255.0" ve "Default Gateway" ile haberleşmeyi sağlayacak olan "192.34.99.1" ip adresimizi yazıyoruz.

DHCP VLAN Yapılandırması

Pencereyi kapatmadan, kullanacağımız VLan ip yapılandırmalarını DHCP sunucumuz üzerinden oluşturmamız gerekiyor. Böylece vlanlara bağlı veya bağlanacak uç cihazlar otomatik olarak ip alabilecek. Üst sekme üzerinden "Services" sekmesini seçin. Sol panelde bulunan DHCP seçeneğini seçtikten sonra servisin çalışması için "Service" seçeneğini "On" duruma getirmemiz gerekiyor.

Daha sonra Topolojimiz de bulunan bütün vlanları tek tek eklememiz gerekiyor. Tek dikkat etmemiz gereken nokta Ip adresi için yaptığımız numaralandırma;
Örnek; 192.34.10.0 - VLAN 10 MUHASEBE
Mavi ile belirtiğim öklet İstanbul'a ait bir Network'e ait olduğunu,
Kırmızı ile belirtiği öklet ise kullanılan vlan numarasına işaret ediyor.
Tabi ki siz böyle yapmak zorunda değilsiniz, ben kolay ayır etmek için bu şekilde ip adreslerini numaralandırdım.
Bu işlemi Vlan 10-99'a kadar tüm vlanlar için tekrarlıyoruz.
Aynı sunucumuz için yaptığımız statik ip ataması gibi... Tek farkı "Pool name" seçeneğine vlan adını yazıyoruz. Böylece hangi network hangi vlana ait kolayca ayırt edebiliyoruz. Gerek duyacağımız vlanları listeye ekledikten sonra pencereyi kapatabiliriz. Şimdilik server ile işimiz kalmadı.

VLAN Oluşturmak

Vlanları merkez Switchler üzerinden tanımlayacağız. Sonuçta VTP ile alt switchlere vlan bilgilerini kolayca aktarabiliyoruz. İlk olarak "IST-MERKEZ" isimli Switchi seçiyoruz.
Açılan pencerenin üst sekmesinden CLI sekmesini seçiyoruz. Bu aşamada switch üzerinden işlem yapabilmek için "enable" komutu ile "privilege" (#) katmanına ulaşmamız gerekiyor. Ardından vlan oluşturabilmek için "conf terminal" komutu ile "configuration"(config) katmanına geçiş yapmamız gerekiyor.
IST-MERKEZ(config)#:vlan 10
IST-MERKEZ(config)#:name MUHASEBE
IST-MERKEZ(config)#:exit
Gördüğünüz komutlar ile vlan 10 oluşturuyor ve "MUHASEBE" ismi veriyoruz.
vlan 10
name MUHASEBE
exit
vlan 20
name URETIM
exit
vlan 30
name PLANLAMA
exit
vlan 40
name PAZARLAA
exit
vlan 50
name ERP
exit
vlan 60
name DEPO
exit
vlan 70
name IK
exit
vlan 88
name ANK-YONETIM
exit
vlan 99
name YONETIM
exit
vlan 998
name BOS
exit
Burada gördüğünüz komutları kopyalayıp, IST-MERKEZ ve ANK-MERKEZ adlı Switchlerimizin config katmanın yapıştırıp uyguluyoruz.
Oluşturmuş olduğumuz vlanları görebilmek için privilege(#) katmanında "show vlan brief" komutu ile listeleyip, görebiliyoruz.

VTP Kullanımı

Merkez Swithclerimiz de vlanlarımızı oluşturduğumuza göre alt switchlerimiz de tekrar tekrar bu işlemi gerçekleştirmemek için VTP kullanacağız. 
Öncelikle bağlantı için kullandığımız interfaceleri düzenlememiz gerekiyor. Vlan Datalarının taşınması için bağlantıları Trunk moduna dönüştürmemiz gerekiyor. Ayrıca oluşturmuş olduğumuz VLAN 998, güvenlik nedeniyle native vlan olarak ayarlamamız gerekiyor.
interface range fa 0/1-3, gig 0/2
switchport mode trunk
switchport trunk native vlan 998
Bu komutları merkez Switchlerimizin config (#) katmanında her ikisine uyguluyoruz. Daha sonra alt switchler için benzer bir çalışma gerçekleştireceğiz.

Şimdi bu bağlantılarımızın diğer ucu olan alt switchlerin, merkez switchlere olan bağlantı interfacelerinin modlarını trunk'a çevirmeliyiz.
interface gig 0/1
switchport mode trunk
switchport trunk native vlan 998
Her alt switch üzerinden yine config (#) katmanında komutları uyguluyoruz. Hepsini başarılı bir şekilde uyguladıktan sonra yaptığımız işlerin doğruluğunu kontrol etmemiz gerekiyor.
Bu işlem için privilege modunda "show interface trunk" komutunu kullanıyoruz. Görüldüğü üzere tüm yaptığımız işlemler başarılı bir şekilde gerçekleşmiş. Aynı komut ile alt switchlerimizin interfacelerini kontrol etmemiz gerekir. Her şey yolunda ise artık VTP yapılandırmasına geçebiliriz.
vtp domain mustafa.oguz
vtp password 123456
vtp version 2
vtp mode server
Merkez switchlerimizin config modunda üstte ki komutları uygulayarak, merkez switchleri Vtp Server olarak yapılandırıyoruz.
vtp domain mustafa.oguz
vtp password 123456
vtp version 2
vtp mode client
Şimdi vlan bilgilerini alacak, alt switchlere Vtp Client olarak yapılandırıyoruz.
Alt switchlerimiz üzerinden "show vlan brief" komutunu uyguladığımız da, merkez switchler üzerinde oluşturmuş olduğumuz vlan bilgilerinin alt switchlere aktarıldığını görebilmekteyiz.

Routerların Birbiri ile Haberleşmesi

Bunun için öncelikle routerlar arasında ki bağlantı olan ağı yapılandırmamız gerekiyor. Bunun için routerların birbirine bakan interfacelerinin aktif hale getirilmesi, ip ataması ve statik yönlendirme yapmamız gerekiyor.
interface fa 0/1
no shutdown
ip address 192.168.0.1 255.255.255.0
ex
!layer 3 katmanı için
ip route 0.0.0.0 0.0.0.0 192.168.0.2
!layer 2 katmanı için
ip route 0.0.0.0 0.0.0.0 fa 0/1
İstanbul routerımız için üstte ki komutları config katmanında uyguluyoruz.
interface fa 0/0
no shutdown
ip address 192.168.0.2 255.255.255.0
ex
!layer 3 katmanı için
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!layer 2 katmanı için
ip route 0.0.0.0 0.0.0.0 fa 0/0
Burada ki komutları Ankara routerımız üzerinde uyguluyoruz. Bu şekilde iki router arasında ki haberleşmeyi sağladık. Şimdi vlanlarımızın birbiri ile haberleşebilmesi için router üzerinde Inter-Vlan (ROAS) yapılandırması gerçekleştirmemiz gerekiyor. Bu işlem aynı zamanda vlanlarımızın gateway adresi olacak.
interface fastEthernet 0/0.10
encapsulation dot1Q 10
ip address 192.34.10.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/0.20
encapsulation dot1Q 20
ip address 192.34.20.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/0.30
encapsulation dot1Q 30
ip address 192.34.30.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/0.99
encapsulation dot1Q 99
ip address 192.34.99.1 255.255.255.0
ip helper-address 192.34.99.100
exit
İstanbul Switchimizin config modunda üstte ki komutları uygulayarak, fastEthernet 0/0 fiziksel interfacemizi, vlanların sayısına göre mantıksal olarak bölüp, ip ataması ve dhcp sunucumuzun adresini gösteriyoruz.
interface fastEthernet 0/1.40
encapsulation dot1Q 40
ip address 192.6.40.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/1.50
encapsulation dot1Q 50
ip address 192.6.50.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/1.60
encapsulation dot1Q 60
ip address 192.6.60.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/1.70
encapsulation dot1Q 70
ip address 192.6.70.1 255.255.255.0
ip helper-address 192.34.99.100
exit
interface fastEthernet 0/1.88
encapsulation dot1Q 88
ip address 192.6.88.1 255.255.255.0
ip helper-address 192.34.99.100
exit
Benzer bir işlemi Ankara Routerımız içinde gerçekleştiriyoruz. Böylece Routerların ve Vlanların haberleşebilmeleri gereken ayarları gerçekleştirmiş olduk.

Alt Switchlerin Bağlantılarına (Interface) Vlan Tanımlamak ve Otomatik IP

Artık sıra uç birim olan bilgisayarlarımıza kendi vlan networkü üzerinden ip aldırmaya geldi. Bunun için uç birimin bağlı olduğu switchimizin üzerinde ki interface portunun modunu değiştirmek ve bu porta vlan ataması yapmamız gerekiyor. Ben bu örneğimde bir switchin uygulamasını gerçekleştireceğim. göstereceğim. Diğer switchlerde vlan numaraları dışında her şey aynı...
interface fastEthernet 0/1
switchport mode access
switchport access vlan 10
exit
Bu işlemi diğer tüm switchlere uyguluyoruz. Tek fark kırmızı ile belirttiğim vlan numarası olmasını istediğimiz vlan numarası ve yeşil ile belirtiğim yer; eğer farklı bir porta tanımlayacaksanız, tanımladığınız port numarasını değiştirmeniz gerekiyor. Şimdi PC0 olan bilgisayarımızın otomatik Ip almasını sağlayalım.
PC0 adlı bilgisayarımızı seçin.
Üst sekmeden "Desktop" sekmesini seçiyoruz. Ardından "Ip Configuration" seçeneğini seçiyoruz.
Varsayılan olarak statik gelen "static" seçeneğini DHCP olarak değiştiriyoruz. Biraz bekledikten sonra sonuç karşınızda! Başarılı bir şekilde clientımız, kendi vlanından DHCP sunucusu sayesinde otomatik Ip almış oldu.
Not: Cisco Packet Tracer yazılımı nedeniyle bu işlemi bir kaç kez tekrarlamanız gerekebilir. Çünkü ilk seferinde Ip alamayabiliyor.

Bir Switchde İkiden Fazla Vlan Tanımlamak

Bu işlemi sağlamak için ikinci bir portu farklı bir vlan ile tanımlamamız gerekiyor.
interface fastEthernet 0/1
switchport mode access
switchport access vlan 60
exit
interface fastEthernet 0/2
switchport mode access
switchport access vlan 70
exit
Yukarıda ki komutları "S6" adlı alt switchimizin config modunda uyguluyoruz. Şimdi bağlı olan bilgisayarlarımıza otomatik Ip aldıralım.
Resimlerden de anlaşıldığı üzere bilgisayarlarımız kendi vlanlarından Ip aldılar.

Haberleşme Kontrolü

Topolojimizi başarılı bir şekilde oluşturduk ve yapılandırdık. Şimdi yaptıklarımızı kontrol etmenin vakti geldi.
Resimde de görüleceği üzere Vlan 30 networküne ait PC2 adlı bilgisayardan, Vlan 70 networküne ait PC6 adlı bilgisayara haberleşmenin olup olmadığını dair ping göndereceğiz.
Bunun için PC2 adlı bilgisayarı seçiyoruz.
Açılan pencereden "Desktop" sekmesi altında "Command Promt" seçeneğini seçin.
Karşımıza gelen komut istemcisine"ping 192.6.70.2" komutunu uyguluyoruz ve biraz bekledikten sonra sonuç karşınızda.
Bu resimde diğer PC üzerinden yaptığımız işlemi tekrarlıyorum. Böylece uç birim olan bilgisayarlar, farklı vlan ve lokasyonda bulunsalar da birbirleri ile veri alışverişinde bulunabiliyorlar...

6 yorum:

  1. hocam teşekkur ederim çok güzle blog olmuş elinize sağlık

    -farklı vlanların misal 10 ve 20 vlanların gatewaydan haberleşiyor router uzerinden ben haberleşmelerini istemiyorum emsala ne yapmak lazım

    YanıtlayınSil
    Yanıtlar
    1. Öncelikle güzel yorumunuz için teşekkür ederim.
      Sorduğunuz soruyu sanırım anladım. Vlanlar kendi içlerinde haberleşebilsinler, lakin farklı vlanlar birbiri ile görüşmesinler istiyorsunuz.
      Bu işlem aslında başlı başına bir konu sayılır. Bu nedenle yorum olarak sadece izleyebileceğiniz yolu gösterebilirim.
      İlk yöntem olarak, yapmak istediğiniz işlemi bir Layer 3 Switch (3560-24PS) ile Vlan Access List (VACL) oluşturabilir ve haberleşmelerini engelleyebilirsin.
      Diğer bir yöntem ise Private Vlan yapısını oluşturup, istediğin vlanları diğer vlanlara karşı izole edebilirsin.
      Bu soru sayesinde bir sonra ki yazımın konusu belli oldu. Bu konuda yakın bir zamanda yazı hazırlayıp, yayınlamayı planlıyorum. Şimdilik bu yorum ile az da olsa sorduğun soruya cevap verebilmişimdir umarım...

      Sil
  2. Merhabalar, cisco packet tracer ile ilgili bir sorum olacaktı.Çok aramama rağmen istatiksel veri toplamayı bulamadım. Bu konuda bir bilginiz var mı ? nasıl istatistik alabilirim ?(wireshark ile ağ izlerken yaptığımız gibi.) Teşekkür ederim

    YanıtlayınSil
    Yanıtlar
    1. Merhaba, İstatistik almaktan tam olarak kastınız nedir? Kurulu network üzerinde paketlerin nasıl dolaştığı mı? Yoksa cihazların üzerinde ki yapılandırma istatistikleri mi?
      Eğer paket dolaşımlarını kastediyorsanız, "Simulation" sekmesini kullanabilirsiniz.
      http://prntscr.com/prrvya

      Sil
    2. hocam paket loss , drop gibi değerleri izleyebilmem mümkün mü ? sniff aracını denedim ancak pek beklediğim sonucu vermedi.Ağ ölçeklendirmesi üzerine bir tez üzerine çalışıyorum ve simülasyon aracı olarak kullanmayı düşündüğüm program bu.Bu açıdan böyle bir araç varsa veya ek paket olarak arayabileceğim bir yer biliyorsanız, paylaşırsanız çok sevinirim.

      Sil
    3. Bildiğim kadarıyla Cisco Packet Tracer üzerinde bunu gerçekleştirmen mümkün değil. Bahsettiğin bu işlemleri canlı (fiziki) sistemler üzerinden gerçekleştirmen gerekiyor. Belki yaptığın araştırmanın boyutunu (network yapısını ve büyüklüğünü) açıklayabilmek için örnek bir network topolojisi oluşturabilirsin...

      Sil